CO-CONV サポート

文章番号24-014

CO-OnSen 管理者ページのボックス一覧画面で「管理 (PC の起動ができていません)」と表示されているボックスの状態について

公開
2024年11月29日
対象製品
  • CO-OnSen

概要

CO-OnSen 管理者ページのボックス一覧画面 において、 ボックスの状態が「管理 (PC の起動ができていません)」となってしまうことがあります。

この状態のボックスでは、メイン・ケーブル両方の LED が赤色点灯状態となっており、PC の貸出ができない状態となっています。(管理者取出しはできます。)

本ドキュメントでは、この状態のボックスが確認された際にどのように対処すべきかのガイドラインを示すことを目的としています。

詳細

「管理 (PC の起動ができていません)」状態について、その背景となる CO-OnSen の PC 管理についての解説と、PC の状態により判別した状況ごとの対処について述べます。

背景

CO-OnSen に格納された PC は必要に応じて CO-OnSen から USB-C ケーブルを介して電源が入れられ、 起動した PC は USB-C ケーブルを介して CO-OnSen 本体内蔵の USB NIC を利用して通信し、 PC の格納先のボックス上で動作する CO-OnSen システムの PC 管理サービスに PC 識別情報や充電率などを報告します。

CO-OnSen に格納されている PC の起動と PC からの報告は、以下の目的のために実施しています。

  • 返却時に QR コードをかざした PC と CO-OnSen に格納されて USB-C ケーブルが接続されている PC とが一致することを確認するため。
    • 返却直後、およびケーブルが抜かれてから接続された場合 (ケーブルを抜いて外部にある別の PC に接続している可能性を想定) に CO-OnSen から PC を起動させて PC に報告させます。
  • メンテナンス時間帯 (通常夜間) に、イメージ管理システム (CO-Colors ほたて や CO-Spray など) に PC からイメージ更新の有無を問い合わせて必要に応じてイメージ更新を実施するため。
    • メンテナンス時間帯 (通常夜間に設定) に CO-OnSen から PC を起動させ、メンテナンス処理の状態を PC に報告させます。。

この PC 起動において、PC の電源を入れた (入れようとした) ものの、一定時間 (通常 30 分) PC からの通信が確認できなかった場合を、 「管理 (PC の起動ができていません)」としています。

判別方法

PC 状態判別チャート

対処

CO-OnSen のボックス一覧画面で「管理 (PC の起動ができていません)」となっている原因はひとつではなく、以下のようなものがあります。

PC を取りだし、以下の各「取り出した PC の状態」のいずれに当てはまるかを確認し、状況に応じた対処を実施して復旧を試みることになります。

A. CO-OnSen が PC を起動できていない場合

取り出した PC の状態

  • 取り出した時点では停止している。
  • 電源を入れると正常に起動する。
  • 取り出した PC を別のボックスに返却すると数分後に「貸出可能」(LED が緑点灯) になる。
  • 管理者格納で当該ボックスに取り出した PC を再度格納すると一定時間 (30 分後 (設定によっては 1 時間後)) 経過後に「管理 (PC の起動ができていません)」になってしまう。

切り分けのための確認

  • 管理者格納で当該ボックスに別の PC を格納すると一定時間 (30 分後 (設定によっては 1 時間後)) 経過後に「管理 (PC の起動ができていません)」になってしまう。

原因

  • CO-OnSen の基板の不具合。
  • CO-OnSen のソフトウェア上の不具合。

対処

  • 問題の発生しているボックスを管理者ページから 運用停止 に した上で CO-CONV にご連絡ください。

B. PC が CO-OnSen 内蔵の USB NIC を認識できていない場合

取り出した PC の状態

  • 取り出したタイミングにより PC は起動していることも停止していることもありうる。
  • 電源を入れると正常に起動する。
  • 取出した PC をボックス、別のボックス、いずれに返却しても数分後に「貸出可能」(LED が緑点灯) になる。

切り分けのための確認

  • 管理者格納で当該ボックスに別の PC を格納すると数分後 (設定によっては 10 分後) に「貸出可能」(LED が緑点灯) になる。

原因

  • PC のデバイス認識に異常に長い時間がかかってしまっている。
    (数十分~数時間後に USB NIC 認識して自然復旧することもあります。)
  • CO-OnSen 内蔵の USB NIC が何らかの理由でリセットできていないことに起因。
  • 一時的な状態であり、物理的に PC から USB-C ケーブルを抜き差ししたすることにより CO-OnSen 内蔵 USB NIC がリセットされることで復旧します。

対処

  • CO-OnSen の USB-C ケーブルを PC から一度抜き差しすると復旧します。

C. PC がシャットダウン時にハングアップした場合

取り出した PC の状態

  • 取り出した時点では、画面は真っ暗で電源 LED は点灯している。(電源は入っているが動作していない。)
  • 電源ボタンを短く押しても停止しない。
  • 電源ボタン長押しすると停止し、その後電源を入れると正常に起動する。

切り分けのための確認

  • 管理者格納で当該ボックスに別の PC を格納すると数分後 (設定によっては 10 分後) に「貸出可能」(LED が緑点灯) になる。

原因

  • PC のシャットダウン時に何らかの要因でハングアップした状態になってしまった。

対処

  • 電源ボタン長押しによる停止の後に電源を入れると起動でき、復旧します。

D. PC が正常に起動できない状態の場合

取り出した PC の状態

  • 取り出した時点では、PC は停止もしくは何らかの BIOS 警告画面。
  • 電源ボタンを長押しして停止してから起動しても正常に起動できない。

切り分けのための確認

  • 管理者格納で当該ボックスに別の PC を格納すると数分後 (設定によっては 10 分後) に「貸出可能」(LED が緑点灯) になる。

原因

  • いくつかの状態があり得ます。
    • PC の故障が疑われる状態。(BIOS 警告音が鳴って起動できない場合など)
    • BIOS の時計がずれてしまって時計の修正を待機する警告で止まっている。
    • イメージ配信に問題があって正常に Windows 起動できない状態。
    • そのほか Windows が正常に起動できない状態。

対処

  • 状況に応じて PC が正常に起動できる状態に復旧する必要があります。
    • 修理、BIOS 設定修復、イメージ配信しなおし、など。
  • 状況の判別ができない場合は CO-CONV にお問い合わせください。

E. USB-C デバイスを認識できない状態の場合

現在のところ Lenovo L13 Yoga Gen 2 でのみ確認されています。

取り出した PC の状態

  • 取り出した時点では停止している。
  • 電源を入れると正常に起動する。
  • USB-C デバイスを接続しても認識できない。(USB-C HDD 等も認識できない。)

切り分けのための確認

  • 管理者格納で当該ボックスに別の PC を格納すると数分後 (設定によっては 10 分後) に「貸出可能」(LED が緑点灯) になる。

原因

  • PC が USB-C デバイスを認識できない状態になってしまっている。

対処

  • 電源ボタンを 15 秒以上長押しして停止した後に起動すると復旧します。
  • 復旧したかどうかは USB-C デバイスを接続して認識できたかどうかで確認できます。